WdBly Blog

懂事、有趣、保持理智

WdBly Blog

懂事、有趣、保持理智

周维 | Jim

603927378@qq.com

Mac下安装CocoaPods

Mac中安装CocoaPods步骤,首先安装RVM,然后安装Ruby, 最后安装cocoaPods, React-Native 0.6以后依赖CocoaPods, 所以我们也需要安装它, CocoaPods是iOS最常用最有名的类库管理工具, 通过CocoaPods可以非常高效的安装iOS依赖

具体安装步骤如下:

首先需要在 Mac 中安装 Ruby 环境rvm

1: 安装rvm 和nvm类似,用于管理Ruby的版本

curl -sSL https://get.rvm.io | bash -s stable

2: 下载成功后设置环境变量

source ~/.rvm/scripts/rvm

rvm -v //检查是否设置成功

3: 设置Ruby china镜像

echo "ruby_url=https://cache.ruby-china.org/pub/ruby" > ~/.rvm/user/db

安装 Ruby

1: 查询可安装版本

rvm list known

image.png

当前最新版本为 2.7.0

2: 开始安装

rvm install 2.7.0

3: 检验安装

ruby -v

安装cocoaPods

1: 开始安装

gem install cocoapods

2: 检验安装

pod -v